全球行情:

当前位置:主  页指标公式 大智慧L2短线套利-黄金兔-芙蓉出水-老鸭头-一剑封喉

短线套利-黄金兔-芙蓉出水-老鸭头-一剑封喉
软件类别: 国产软件 / 大智慧L2公式
授权方式: 免费软件

 

软件语言:简体中文
软件大小:20.93 KB
更新时间:2014-11-01
联系方式:QQ :1078885852

 

点击大图:
插件情况:

运行环境:WinXP/Win2000/Win2003/WinVista/Win7/Win8/Win10

软件简介

{短线套利+黄金兔}
{N1:0,0,100,37; N2:0,0,100,37; N3,0,0,100,27; }
{短线均线设为6日和18日。
积极获利法=今日收盘价站上6日均价千分之四处,6日线均线走多。
加码买进条件=今日收盘价站上18日均价千分之四处,18日线均线走平或走多。
指标用法:
买入条件:6日均线走多并发出买进信号可介入,18日均线走平或走多并发出加码信号,可加码介入。
卖出条件:当日收盘价下穿6日均线的千分之四处,且6日均线拐头向下,卖出;
连续两日收盘价跌破18日均线,18日均线走平或走空,卖出。}
aVar1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
aVar2:=EMA(aVar1,N3);
zc:=CROSS(aVar1,aVar2) AND TROUGHBARS(3,7,1)<1;
DRAWTEXT(zc,h+0.05,'㊣'),coloryellow;
DRAWTEXT(zc,l,'震仓*'),coloryellow;
{趋势线}
Var1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
Var4:=CROSS(Var3,0.9);
Var5:=IF(Var2,HIGH,IF(Var4,LOW,0));
趋势线:=zig(3,6);
DRAWTEXT(CROSS(ZIG(3,6),TROUGHBARS(3,6,1)),HIGH*1.008,'加仓'),linethick1;
Var6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
Var7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
Var8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
Var9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VarA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VarB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
drawtext((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),l-0.02,'买'),colorred;
ma5:ma(c,5),colorwhite,linethick2;
ma18:ma(c,18),color0099ff,linethick2;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
A:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));
t1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
t2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(t1,A,A),ColorFF00FF,POINTDOT;
STICKLINE(t1,A,A,9,0),ColorFF00FF;
波谷:IF(t2,B,B),Color80FF00,POINTDOT;
STICKLINE(t2,B,B,9,0),Color80FF00;
买进价:=((c-ref(ma5,1))/5+ma5)*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
白买进:IF(买进条件,l,h),COLORWHITE,POINTDOT;
STICKLINE(买进条件,h,l,0,1),colorwhite,linethick2;
STICKLINE(买进条件,o,c,4,1),colorwhite,linethick2;
加码价:=((c-ref(ma18,1))/18+ma18)*1.004;
加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);
黄加码:IF(加码条件,l,h),coloryellow,POINTDOT;
STICKLINE(加码条件,h,l,0,1),coloryellow,linethick2;
STICKLINE(加码条件,o,c,4,1),coloryellow,linethick2;
现价:CLOSE,POINTDOT,Color000F89;
DRAWICON(CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)) ,low*0.98,1);
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)) ,high*1.02,2);
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.99,'买') , COLORRED,linethick1;
STICKLINE(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),H,L,0.5,1),COLORRED,linethick2;
STICKLINE(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),O,C,6,1),COLORRED,linethick2;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.008,'卖') , ColorFF9F80,linethick1;
STICKLINE(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),H,L,0.5,1),ColorFF9F80,linethick2;
STICKLINE(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),O,C,6,1),ColorFF9F80,linethick2;
{黄金兔}
ma20:=ma(c,20);
ma120:=ma(c,120);
ma250:=ma(c,250);
乖离线:=((c-ref(ma20,1))/20+ma20)*1.20;
tt1:=cross(ma20,ma120) and cross(ma20,ma250) and v>ref(v,1);
tt2:=ma20>ref(ma20,2) and v>ref(v,1) and cross(c,ma20);
STICKLINE(TT1,l,l-0.09,4,0),coloryellow;
DRAWTEXT(TT1,l-0.10,'金叉'),coloryellow;
DRAWTEXTABS(300,2,'金盾股票园 www.xu5188.com'),COLOR889999,LINETHICK3;
STICKLINE(cross(c,ma120) and cross(c,ma250) and cross(c,ma20),l,l-0.05,4,0),coloryellow;
DRAWTEXT(cross(c,ma120) and cross(c,ma250) and cross(c,ma20),l-0.10,'并线开花'),coloryellow;
STICKLINE(cross(c,乖离线),h,h+0.09,4,0),color00ff00;
DRAWTEXT(cross(c,乖离线) ,h+0.13,'走人'),color00ff00;
STICKLINE(ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),l,l-0.09,4,0),colorf00ff0 ;
DRAWTEXT(ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),l-0.13,'大胆进'),colorf00ff0 ;
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
DRAWTEXT(FILTER(((((((((OPEN > ma120) AND (ma20 < ma120)) AND (LOW <= ma120)) AND ((ma20 - REF(ma20,1)) > 0)) AND (CLOSE > OPEN)) AND ((ma120 - REF(ma120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= ma120)),15),LOW,'★'),color00ff00;
DRAWTEXT(FILTER(((((((((OPEN > ma120) AND (ma20 < ma120)) AND (LOW <= ma120)) AND ((ma20 - REF(ma20,1)) > 0)) AND (CLOSE > OPEN)) AND ((ma120 - REF(ma120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= ma120)),15),LOW,'120跳马'),color00ff00;
AA:=CROSS(MA(C,5),MA(C,20))AND CROSS(MA(C,5),MA(C,30))AND CROSS(MA(C,5),MA(C,60));
BB:=MA(C,60)>MA(C,10)AND CROSS(MA(C,10),MA(C,30))AND MA(C,30)>MA(C,20)AND ABS(MA(C,60)-MA(C,20))/MA(C,20)<0.05;
CC:=MA(C,30)>MA(C,5)AND CROSS(MA(C,5),MA(C,20))AND MA(C,20)>MA(C,10);
DD:=ABS((MA(C,5)-MA(C,10))+(MA(C,10)-MA(C,20))+(MA(C,20)-MA(C,30)))<0.02 AND MA(C,5)>REF(MA(C,5),1)AND MA(C,10)>REF(MA(C,10),1);
EE:=MA(C,20)>MA(C,5)AND CROSS(MA(C,5),MA(C,10))AND MA(C,10)>MA(C,60)AND ABS(MA(C,20)-MA(C,60))/MA(C,60)<0.05;
FF:=AA OR BB OR CC OR DD OR EE;
天堂:=FF AND FILTER(FF,8);
DRAWICON(天堂,L,9),COLORYELLOW;
DRAWTEXT(天堂,L*0.99,'▲'),COLORred;
STICKLINE(天堂,H,L,0.5,0),COLORYELLOW;
STICKLINE(天堂,O,C,6,0),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(FF1,l*0.99,'黄金兔'),COLORred;
STICKLINE(FF1,H,L,0.5,0),COLORRED;
STICKLINE(FF1,O,C,6,0),COLORRED;

{一剑封喉}
VAR41:=((AMOUNT / VOL) / 100);
VAR42:=(((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7);
VAR43:=((SUM(AMOUNT,5) / VAR41) / 100);
VAR44:=((SUM(AMOUNT,13) / VAR41) / 100);
VAR45:=((SUM(AMOUNT,34) / VAR41) / 100);
CYC5:=DMA(VAR42,(VOL / VAR43));
CYC13:=DMA(VAR42,(VOL / VAR44));
CYC34:=DMA(VAR42,(VOL / VAR45));
CYC∞:=DMA(VAR42,(VOL / CAPITAL));
一剑封喉:=((CROSS(CLOSE,MA(CLOSE,13)) AND CROSS(CLOSE,MA(CLOSE,34))) AND CROSS(CLOSE,MA(CLOSE,55)));
A41:=(((CLOSE - LLV(LOW,22)) / (HHV(HIGH,22) - LLV(LOW,22))) * 100);
A42:=(((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100);
A44:=((3 * SMA(A41,5,1)) - (2 * SMA(SMA(A42,5,1),3,1)));
DRAWTEXT((一剑封喉 AND (A44 < 30)),(LOW * 0.98),'一剑封喉'),Color00FF00;
STICKLINE(一剑封喉,H,L,0.5,0),Color00FF00;
STICKLINE(一剑封喉,O,C,6,0),Color00FF00;
{芙蓉出水}
MA40:=MA(CLOSE,40);
ma60:=ma(c,60);
aa:=BARSLAST(ma60>ma40 and (ma40=ma20 or ma40>ma20));
bb:=ref(count(c<ma60,aa)=aa,1);
cc:=cross(c,ma60) and vol>ma(vol,5) and (c-ref(c,1))/ref(c,1)*100>3;
芙蓉出水:=bb and cc;
drawtext(芙蓉出水,h*1.05,'★'),Color0080FF;
drawtext(芙蓉出水,h*1.02,'芙蓉出水'),Color0080FF;
stickline(芙蓉出水,h,l,0.5,0),Color0080FF;
stickline(芙蓉出水,o,c,5,0),Color0080FF,linethick2;

{老鸭头}
mMA5:=MA(close,5);
mMA10 :=MA(close,10);
mMA60 :=MA(close,60);
pday1 := barslast(cross(mma5,mma60));{5日均线上穿60日均线}
pday2 := barslast(cross(mma10,mma60));{10日均线上穿60日均线,至此形成鸭颈部}
pday3 := barslast(high=hhv(high,pday2));{形成头部,要下跌}
pday4 := barslast(cross(mma10,mma5){ or (ref(mma10,1)<ref(mma5,1) and mma5=mma10)});{下跌后,5日均线和10日均线死叉}
pday5 := barslast(cross(mma5,mma10){ or (ref(mma5,1)=ref(mma10,1) and mma5>mma10)});{回落不久,5日均线和10日均线形成金叉,形成部}
a1b:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;
a2b:= count(cross(mma10,mma5),pday2)=1;
a3b:=mma5>mma60 and mma10>mma60;
老鸭头:=(A1b AND A2b and a3b) and FILTER(A1b AND A2b and a3b ,5);
drawtext(老鸭头,l,'老鸭头'),coloryellow;
stickline(老鸭头,h,l,0.5,0),coloryellow;
stickline(老鸭头,o,c,6,1),coloryellow,linethick3;

请点击下图进入下载
赞助商链接
下载说明

☉为了达到最快的下载速度,推荐使用迅雷下载本站软件。

☉使用解压缩软件才能正常解压本站提供的软件!
☉下载本站资源,如果服务器暂不能下载请过一段时间重试!

☉本站统一解压码:www.xu5188.com
☉如果遇到什么问题,请联系我们

 

本网提供的公式文件说明:
☉alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
☉fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
☉exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
☉tnc格式股票公式,可以用通达信股票软件引入使用;
☉tni格式股票公式,仅可以用通达信新版本引入使用例如通达信v6.05以上版本,通达 信老版本不能引入;
☉hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

☉关于股票公式源码编辑:本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本网就可以有资 料说明编写过程。

网站地图关于我们免责声明联系站长金盾股票园京ICP备10015640号在线QQ:1078885852