全球行情:

当前位置:主  页指标公式 飞狐公式先胜黄金分割线

先胜黄金分割线
软件类别: 国产软件 / 飞狐公式
授权方式: 免费软件

 

软件语言:简体中文
软件大小:15.38 KB
更新时间:2014-11-19
联系方式:QQ :1078885852

 

点击大图:
插件情况:

运行环境:WinXP/Win2000/Win2003/WinVista/Win7/Win8/Win10

软件简介

{先胜黄金分割线}

input:H1(158,1,300),P(20,1,100),N8(4,1,100),P1(5,1,100);
主线:=(WMA(CLOSE,P1) * 0.98);
VAR1:=POW((CLOSE - 主线),1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
阻力线:=(主线 + (1.96 * VAR3));
支撑线:=(主线 - (1.96 * VAR3));
PARTLINE(((主线 > REF(主线,1)) AND (阻力线 <> 支撑线)),主线),LINETHICK3,colorFF;
PARTLINE((主线 < REF(主线,1)),主线),LINETHICK2,colorFF0000;
DRAWICON((主线 > REF(主线,1)),主线,10);
N1:=SYSPARAM(3);
N:=((N1 - SYSPARAM(2)) + 1);
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
最高:HH[N1],colorFF;
最低:LL[N1],colorFF;
(最低 + ((最高 - 最低) * 0.191));
(最低 + ((最高 - 最低) * 0.382));
(最低 + ((最高 - 最低) * 0.5)),colorFF00FF;
(最低 + ((最高 - 最低) * 0.618));
(最低 + ((最高 - 最低) * 0.809));
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'000%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'19.1%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'38.2%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'50%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'61.8%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'80.9%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'100%↑'),colorFFFF;

VAR1:=WINNER(CLOSE);
VAR2:=(VOL / CAPITAL);
VAR3:=(VAR2 / VAR1);
财神线:=IF((VAR1 < (N1 / 100)),VAR3,0);
DRAWICON((财神线 > 3),LOW,10),ALIGN5;
VAR1:=WINNER(CLOSE);
VAR2:=(VOL / CAPITAL);
VAR3:=(VAR2 / VAR1);
财神线:=IF((VAR1 < (N1 / 100)),VAR3,0);
财神到:=财神线;
DRAWICON((((财神线 < REF((财神线 > 1),1)) AND (财神线 > 0.5)) AND (财神线 < 1)),HIGH,1),ALIGN5;
VAR1111:=FORCAST(CLOSE,5);

STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color8800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),colorFF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),color8800;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),color9900;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),colorAA00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),colorBB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),colorCC00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),colorDD00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),colorEE00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),colorFF00;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),colorFF;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),colorEEFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color22FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color44FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color66FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color88FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),colorAAFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),colorCCFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),colorEEFF;
DRAWNUMBER((SYSPARAM(2) = BARPOS),CLOSE,FINANCE(33),2),ALIGN5;
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,' -收益'),ALIGN5;

STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color8800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),colorFF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),color8800;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),color9900;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),colorAA00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),colorBB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),colorCC00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),colorDD00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),colorEE00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),colorFF00;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),colorFF;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),colorEEFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color22FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color44FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color66FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color88FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),colorAAFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),colorCCFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),colorEEFF;
VAR1:=(((CLOSE + HIGH) + LOW) / 3);
CB:=MA(VAR1,4);
A1:=HHV(CB,18);
A2:=HHV(CB,41);
A3:=(HHV(HIGH,62) * 0.98);
B1:=LLV(CB,18);
B2:=(LLV(LOW,62) * 1.02);
MID:=MA(CLOSE,20);
UPPER:=(MID + (2 * STD(CLOSE,20)));
LOWER:=(MID - (2 * STD(CLOSE,20)));
VAR18:=((EMA(CLOSE,3) - EMA(CLOSE,6)) - ((EMA(CLOSE,6) - EMA(CLOSE,12)) * (0 - 100)));
VAR28:=EMA(VAR18,3);
VAR38:=((EMA(CLOSE,3) - EMA(CLOSE,6)) - ((EMA(CLOSE,24) - EMA(CLOSE,36)) * (0 - 100)));
VAR48:=EMA(VAR38,9);
VAR58:=CROSS(VAR18,VAR28);
VAR36:=CROSS(VAR28,VAR18);
STICKLINE(VAR36,OPEN,CLOSE,1.5,0),colorFFFFFF;
STICKLINE(VAR58,OPEN,CLOSE,8,0),colorFF;
STICKLINE(VAR58,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.33)),8,0),colorFFFF;
STICKLINE(VAR58,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.66)),8,0),LINETHICK2,colorFF00FF;

拐点:=MA(CLOSE,N8);
拐点1:=MA(CLOSE,N8);
GD1:=(REF((COUNT((拐点 <= REF(拐点,1)),5) = 5),1) AND (拐点 > REF(拐点,1)));
GD2:=(REF((COUNT((拐点1 <= REF(拐点1,1)),5) = 5),1) AND (拐点1 > REF(拐点1,1)));
DRAWICON(GD1,(LOW * 0.99),8);
DRAWICON(GD1,(LOW * 0.98),1);
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,''),ALIGN4,colorFFFF;
KXS:=SYSPARAM(1);
MID:=MA(CLOSE,20);
UPPER:=(MID + (2 * STD(CLOSE,20)));
LOWER:=(MID - (2 * STD(CLOSE,20)));
V1:=(((CLOSE - LOWER) / (UPPER - LOWER)) * 100);
V2:=(V1 - EMA(V1,5));
K1:=(SUM(LLV(V2,4),4) / 4);
V3:=(EMA(V2,64) * 10);
V4:=EMA(((0.4 * V2) * (0 - 1)),3);
V5:=(0 - ((1 * EMA(V2,39)) * 10));
A:=(V3 > 10);
B:=(V2 > V4);
D:=(V5 > 10);
E:=(((V3 <= 10) OR (V2 <= V4)) OR (V5 <= 10));
KS:=(((CLOSE - SMA(CLOSE,13,1)) / SMA(CLOSE,13,1)) * (0 - 100));
RKS:=REF(KS,1);
MLS:=((((RKS / KS) > 1.23) AND (RKS > 13)) AND ((CLOSE / REF(CLOSE,1)) > 1.03));
开:=OPEN;
高:=HIGH;
低:=LOW;
收:=CLOSE;
超跌:STICKLINE((KS > 13),高,低,0,1),LINETHICK2,colorFFFFFF;
反弹:STICKLINE((MLS = 1),高,低,0,1),LINETHICK2,colorFF00FF;
STICKLINE((KS > 13),开,收,8,1),LINETHICK2,colorFFFFFF;
STICKLINE((MLS = 1),开,收,8,1),LINETHICK2,colorFF00FF;
VAR1:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR2:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR3:=(MA(CLOSE,27) + (2 * STD(CLOSE,27)));
DRAWICON(CROSS(VAR2,VAR3),(HIGH * 1.035),3);
DRAWTEXT(CROSS(VAR2,VAR3),(HIGH * 1.02),''),colorFF00;
上:=(MA(HIGH,30) * 1.15);
中1:=(MA(HIGH,3) * 1.03);
中2:=(MA(LOW,3) * 0.97);
下:=(MA(LOW,30) * 0.85);
上通道:=(EMA(EMA(EMA(HIGH,5),5),5) * 1.05);
DRAWTEXT(FILTER(((HIGH > 上通道) AND (CLOSE < 上通道)),3),(HIGH * 1.04),'●逃'),colorEE00FF;

短期乖离率:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
趋势:=(((5 * SMA((((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 80),5,1)) - (3 * SMA(SMA((((CLOSE - LLV(LOW,7)) / (HHV(HIGH,7) - LLV(LOW,7))) * 80),5,1),3,1))) - SMA(SMA(SMA((((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 80),5,1),3,1),2,1));
趋势1:=MA(MA(趋势,5),3);
平衡线:=EMA(EMA(EMA(HIGH,3),3),1);
回挡线:=(平衡线 * 0.92);
DRAWICON(((CROSS(趋势,0) AND (短期乖离率 > 3)) AND ((回挡线 - REF(回挡线,1)) > 0)),LOW,0);
中期大底:=(LLV(LOW,30) * 1.01);
DRAWTEXT((((LOW <= 中期大底) AND ((回挡线 - REF(回挡线,1)) >= (0 - 0.99999))) AND ((CLOSE / OPEN) > 1.025)),LOW,'买吧'),colorFFFF;
VAR2:=(平衡线 * 0.84);
了结线:=(平衡线 * 1.06);
主线:=WMA(CLOSE,8);
VAR1:=POW((CLOSE - 主线),1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
WX:=MA(CLOSE,0);
M1:=(MA(CLOSE,15) * IF((20 < 5),WX,1));
M2:=(MA(CLOSE,20) * IF((20 < 7),WX,1));
DRAWTEXT((((((((REF(CLOSE,1) < M2) AND ((主线 - REF(主线,1)) > 0)) AND ((了结线 - REF(了结线,1)) > 0.01)) AND (LOW < M2)) AND (CLOSE > M2)) AND ((M1 - REF(M1,1)) > 0)) AND ((CLOSE / OPEN) > 1.052)),(LOW - 0.08),'★打劫'),colorFFFF;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
实时线:MA(CLOSE,1),Color006900;
神秘线:HY1,Color400080;

DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH, (((((((((((((((((((((((((((((((((('所属板 块:' + BLKNAME) + '\n') + '发行价') + NUMTOSTR(FINANCE (51),2)) + '元') + ' 发行量') + NUMTOSTR(FINANCE(52),2)) + '万股') + '\n') + '总股本') + NUMTOSTR(FINANCE(1),0)) + '万 股') + ' 流通A股') + NUMTOSTR(FINANCE(7),0)) + '万股') + ' 净资产') + NUMTOSTR(FINANCE(35),2)) + '亿元') + ' 每股收 益') + NUMTOSTR(FINANCE(33),2)) + '元') + ' 每股未分配') + NUMTOSTR(FINANCE(32),2)) + '元') + '\n') + '市盈率') + NUMTOSTR(DYNAINFO(39),2)) + '%') + ' 投资收益') + NUMTOSTR(FINANCE(24),2)) + '元') + ' 股东总数') + NUMTOSTR(FINANCE(50),0)) + '户')),ALIGN4,colorFF00;

b:=BARSCOUNT(C)=SYSPARAM(2);
d:=BARSLAST(b);
hh:=hhv(h,d);

DRAWTEXTEX(1,1,5,230,'金盾股票园 www.xu5188.com'),ColorC0C0C0;

MA10:=MA(CLOSE,10);
平均值:=((MA10 / -10) + MA10);
MX:=((平均值 * 2) * 0.54);
MA13:=MA(CLOSE,13);
MA34:=MA(CLOSE,25);
DRAWTEXT(FILTER((((((((上 - REF(上,1)) > 0) AND (短期乖离率 < (0 - 4))) AND (CLOSE < OPEN)) AND (LOW <= MA34)) AND (CLOSE < MA13)) AND ((MX - REF(MX,1)) > 0)),1),LOW,'★破多买入'),colorFFFFFF;
短期底:=(LLV(HIGH,30) * 0.93);
DRAWTEXT((((LOW <= 短期底) AND (CLOSE < MX)) AND (短期乖离率 > (0 - 8))),(LOW - 0.15),'★涨20%'),colorFF00;

请点击下图进入下载
赞助商链接
下载说明

☉为了达到最快的下载速度,推荐使用迅雷下载本站软件。

☉使用解压缩软件才能正常解压本站提供的软件!
☉下载本站资源,如果服务器暂不能下载请过一段时间重试!

☉本站统一解压码:www.xu5188.com
☉如果遇到什么问题,请联系我们

 

本网提供的公式文件说明:
☉alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
☉fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
☉exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
☉tnc格式股票公式,可以用通达信股票软件引入使用;
☉tni格式股票公式,仅可以用通达信新版本引入使用例如通达信v6.05以上版本,通达 信老版本不能引入;
☉hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

☉关于股票公式源码编辑:本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本网就可以有资 料说明编写过程。

网站地图关于我们免责声明联系站长金盾股票园京ICP备10015640号在线QQ:1078885852