全球行情:

当前位置:主  页指标公式 飞狐公式徐老看盘

徐老看盘
软件类别: 国产软件 / 飞狐公式
授权方式: 免费软件

 

软件语言:简体中文
软件大小:34.58 KB
更新时间:2014-11-19
联系方式:QQ :1078885852

 

点击大图:
插件情况:

运行环境:WinXP/Win2000/Win2003/WinVista/Win7/Win8/Win10

软件简介

{徐老看盘}

qw1:=(最高价+最低价+收盘价*2)/4;
qw3:=指数平滑移动平均(qw1,10);
qw4:=估算标准差(qw1,10);
qw5:=(qw1-qw3)*100/qw4;
qw6:=指数平滑移动平均(qw5,5);
rk7:=指数平滑移动平均(qw6,10);
涨:指数平滑移动平均(qw6,10)+100/2-5,linethick1,colorred;
跌:指数平滑移动平均(涨,4),linethick1,colorFFFF34;
多线:条件函数(交叉函数(涨,跌) and 跌<-10,30,0),linethick1,COLORFF00FF;
空线:条件函数(交叉函数(跌,80),70,100),color0099ff,linethick1;
买1:指数平滑移动平均(跌,4),colorwhite;
买2:指数平滑移动平均(买1,4),colorgreen;
买m3:=指数平滑移动平均(买2,4),coloryellow;
买m4:=指数平滑移动平均(买m3,4),colorcc9900;
-10,点状线,color888888,linethick2;
80,点状线,color888888,linethick2;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),0,0 ),colorwhite;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),8,0 ),COLOR008800;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),7,0 ),COLOR009900;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),6,0 ),COLOR00AA00;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),5,0 ),COLOR00BB00;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),4,0 ),COLOR00CC00;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),3,0 ),COLOR00DD00;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),2,0 ),COLOR00EE00;
画柱线(涨<向前引用(涨,1),涨,简单移动平均(涨,3),1,0 ),COLOR00FF00;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),0,0) ,COLOR00BBFF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),8,0) ,COLOR0011FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),7,0) ,COLOR0022FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),6,0) ,COLOR0044FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),5,0) ,COLOR0066FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),4,0) ,COLOR0088FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),3,0) ,COLOR0099FF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),2,0) ,COLOR00AAFF;
画柱线(涨> 向前引用(涨,1),涨,指数平滑移动平均(涨,3),1,0) ,COLOR00BBFF;
画图标(多线,30,1),COLORFF00FF;
画图标(交叉函数(跌,80),70,2),colorgreen;
显示文字(交叉函数(涨,跌) and 跌<20 and 跌>-10,40,'买入'),colorccff99;
显示文字(多线>0,-20,'看涨'),color0000ff;
Var811:=累加到指定值周期数(成交量,财务数据(7)*100);
Var822:=动态移动平均(指数平滑移动平均(收盘价,12),求和(成交量,5)/3/流通盘大小);
Var883:=(收盘价-Var822)/Var822*100;
Var884:=最高值(Var883,Var811);
Var885:=最低值(Var883,Var811);
Var886:=(Var883-Var885)/(Var884-Var885)*100;
K:=移动平均(Var886,3,1);
D:=移动平均(K,3,1);
J:=3*K-2*D;
MA1:=简单移动平均(J,3),colorgreen;
画柱线(信号过滤(J>MA1 AND J<=3,5)=1 and 跌<0,涨,涨+20,6,0),coloryellow;
显示文字(信号过滤(J>MA1 AND J<=3,5)=1 and 跌<0,60,'考虑买进'),colorffffff;
Var1:=简单移动平均(收盘价,152);
Var2:=简单移动平均(收盘价,194);
Var3:=Var2+2*估算标准差(收盘价,170);
Var4:=Var1+2*估算标准差(收盘价,170);
顶:(收盘价>Var3)*13*10,colorblue,linethick2;
Var6:=指数平滑移动平均(最高值(最高价,500),21);
Var7:=指数平滑移动平均(最高值(最高价,250),21);
Var8:=指数平滑移动平均(最高值(最高价,90),21);
Var9:=指数平滑移动平均(最低值(最低价,500),21);
VarA:=指数平滑移动平均(最低值(最低价,250),21);
VarB:=指数平滑移动平均(最低值(最低价,90),21);
VarC:=指数平滑移动平均((Var9*0.96+VarA*0.96+VarB*0.96+Var6*0.558+Var7*0.558+Var8*0.558)/6,21);
VarD:=指数平滑移动平均((Var9*1.25+VarA*1.23+VarB*1.2+Var6*0.55+Var7*0.55+Var8*0.65)/6,21);
VarE:=指数平滑移动平均((Var9*1.3+VarA*1.3+VarB*1.3+Var6*0.68+Var7*0.68+Var8*0.68)/6,21);
VarF:=指数平滑移动平均((VarC*3+VarD*2+VarE)/6*1.738,21);
Var10:=向前引用(最低价,1);
Var11:=移动平均(绝对值(最低价-Var10),3,1)/移动平均(最大值(最低价-Var10,0),3,1)*100;
Var12:=指数平滑移动平均(条件函数(收盘价*1.35<=VarF,Var11*10,Var11/10),3);
Var13:=最低值(最低价,30);
Var14:=最高值(Var12,30);
Var15:=条件函数(简单移动平均(收盘价,58),1,0);
Var16:=指数平滑移动平均(条件函数(最低价<=Var13,(Var12+Var14*2)/2,0),3)/618*Var15;
Var17:=条件函数(Var16>50,50,Var16)/3.82*6;
Var18:=最高值(最高价,30);
Var19:=最低值(最低价,30);
NL:=指数平滑移动平均((收盘价-Var19)/(Var18-Var19)*100,5)/8*10,coloryellow,linethick2;
Var1A:=(指数平滑移动平均(成交额,5)/指数平滑移动平均(成交量,5)/100-指数平滑移动平均(成交额,125)/指数平滑移动平均(成交量,125)/100)/(指数平滑移动平均(成交额,5)/指数平滑移动平均(成交量,5)/100)<-0.4;
Var1B:=(收盘价-最低值(最低价,15))/(最高值(最高价,15)-最低值(最低价,15))*100;
Var1C:=移动平均(Var1B,3,1);
Var1D:=移动平均(Var1C,3,1);
Var1E:=(-100)*(最高值(最高价,52)-收盘价)/(最高值(最高价,52)-最低值(最低价,52));
Var1F:=统计总数(Var1A,5)>=1 AND (Var1E<-99.9 OR Var1D<15 AND Var1C<12);
Var20:=成交量/财务数据(7);
Var21:=100*获利盘比例(收盘价);
Var22:=简单移动平均(Var21,3);
Var23:=简单移动平均(Var20,34);
Var24:=Var22<Var23*100 AND Var21<Var20;
Var25:=求和(条件函数(收盘价>向前引用(收盘价,1),1,0),0);
Var26:=累加到指定值周期数(成交量,流通盘大小);
Var27:=条件函数(收盘价>最低值(收盘价,Var26),1,-1)*条件函数(Var25>最低值(Var25,Var26),1,-1);
Var28:=统计总数(条件函数(Var27=-1,1,0)=1,8)>2;
Var29:=(收盘价-动态移动平均((3*最高价+最低价+开盘价+2*收盘价)/7,成交量/(求和(成交额,13)/(成交额/成交量/100)/100)))/动态移动平均((3*最高价+最低价+开盘价+2*收盘价)/7,成交量/(求和(成交额,13)/(成交额/成交量/100)/100))*100<-18;
Var2A:=(收盘价-最小值(向前引用(收盘价,5)*0.865,向前引用(收盘价,21)*0.772))/收盘价<0.01;
Var2B:=Var28 AND Var29 AND Var2A;
Var2C:=成交量/流通盘大小>=0.02 AND 成交量/流通盘大小<=0.2 AND 开盘价=1.105;
Var2D:=Var2C AND 统计总数(Var2C,5)=1;
Var2E:=Var2B OR Var2C;
Var2F:=向前引用(收盘价,1);
Var30:=移动平均(最大值(收盘价-Var2F,0),7,1)/移动平均(绝对值(收盘价-Var2F),7,1)*100;
Var31:=移动平均(最大值(收盘价-Var2F,0),13,1)/移动平均(绝对值(收盘价-Var2F),13,1)*100;
Var32:=Var30<20 AND Var31<25;
Var33:=Var32;
Var34:=求和(条件函数(收盘价>向前引用(收盘价,1),成交量,条件函数(收盘价<向前引用(收盘价,1),0-成交量,0)),0);
Var35:=条件函数(收盘价>最低值(收盘价,Var26),1,-1);
Var36:=条件函数(Var34>最低值(Var34,Var26),1,-1);
Var37:=Var35*Var36;
Var38:=条件函数(Var37=-1,1,0);
Var39:=Var38 AND 收盘价=最低值(收盘价,120) AND Var21<Var20;
Var3A:=条件函数(信号过滤(Var1F AND Var24 AND Var2E AND Var33 AND Var39>0,4),70,0);
显示文字(信号过滤(Var24 AND Var2E AND Var33 OR Var33 AND Var39,1),Var2*4-13,'抄底'),colorred;
画柱线(条件函数(Var24 AND Var2E AND Var33 OR Var33 AND Var39,35,0),0,Var2*4-4,15,0);
Var3B:=(收盘价-最低值(最低价,36))/(最高值(最高价,36)-最低值(最低价,36))*100;
Var3C:=移动平均(Var3B,3,1);
Var3D:=移动平均(Var3C,3,1);
Var3E:=移动平均(Var3D,3,1);
Var3F:=交叉函数(Var3D,Var3E) AND Var3D<20;
Var40:=交叉函数(Var3E,Var3D) AND Var3D>80;
Var41:=5;
显示文字(交叉函数(Var41,NL),30,'★做底'),colorwhite;
Var42:="RSI#WEEK"(12,12,12);
Var43:="RSI#WEEK"(55,55,55);
Var44:=向前引用(收盘价,1);
Var45:=移动平均(最大值(收盘价-Var44,0),6,1)/移动平均(绝对值(收盘价-Var44),6,1)*100;
Var46:=信号过滤(Var40,5)=1 AND 上一次条件成立位置(交叉函数(Var42,Var43) AND Var42<=60)>=20;
画柱线(交叉函数(Var42,Var43) AND Var42<=60,0,Var2*15+5,3,0),colormagenta;
显示文字(交叉函数(Var42,Var43) AND Var42<=60,(Var2*12+3)/1,'加仓'),colormagenta;
画柱线(交叉函数(84,Var45),0,Var2*15+3,5,1),colorgreen;
画柱线(Var46,Var2*15+10,10,6,0.3),colorgreen ;
{IF(CROSS(84,Var45),DRAWTEXT(CROSS(84,Var45),80,'防空警报'),IF(Var46,DRAWTEXT(Var46,100,'减仓'),0)),colorgreen ,;}
显示文字(交叉函数(84,Var45),80,'防空警报'),colorgreen ,;
显示文字(Var46,100,'减仓'),colorgreen ,;
Var47:=指数平滑移动平均(100*(收盘价-最低值(最低价,100))/(最高值(最高价,100)-最低值(最低价,100)),5);
Var48:=(收盘价-最低值(收盘价,126))/(最高值(收盘价,126)-最低值(收盘价,126))*100;
Var49:=指数平滑移动平均(收盘价,2)-指数平滑移动平均(收盘价,150);
Var4A:=指数平滑移动平均(Var49,100);
Var4B:=2*(Var49-Var4A);
Var4C:=乘幂(Var4B,3)*0.1+乘幂(Var4B,1);
Var4D:=开平方(开平方(最低价*最高价*开盘价*收盘价));
Var4E:=指数平滑移动平均(Var4D*0.97,3);
Var4F:=(最高价+最低价+收盘价)/3;
Var50:=(Var4F-简单移动平均(Var4F,14))/(0.015*平均绝对偏差(Var4F,14));
Var51:=条件函数(Var4B>0.1,Var4C,0)*5;
Var52:=最低值(最高价,240);
Var53:=100*(收盘价-Var52)/Var52;
Var54:=成交额/成交量;
Var55:=指数平滑移动平均((获利盘比例(收盘价*1.1)-获利盘比例(收盘价*0.9))*80,5);
Var56:=对应大盘收盘价;
Var57:=简单移动平均(Var56,5);
Var58:=简单移动平均(Var56,20);
Var59:=简单移动平均(Var56,30);
Var5A:=Var59>Var57*1.08 AND Var58>Var57*1.055;
Var5B:=Var57>Var56*1.03 AND Var58>Var56*1.13;
Var5C:=Var5B;
Var5D:=条件函数(信号过滤(Var55<6,5)=1,1,0);
Var5E:=(Var5D AND Var53<-2.5 AND Var47<5 AND Var48=0)*60;
Var5F:=Var55<6 AND Var5C;
Var60:=条件函数(信号过滤(Var5F,1)=1,1,0)*80;
Var61:=Var5F AND Var5D*80;
Var62:=交叉函数(Var51,2);
Var63:=交叉函数(Var51,4);
Var64:=(收盘价-简单移动平均(收盘价,6))/简单移动平均(收盘价,6)*100;
Var65:=(收盘价-简单移动平均(收盘价,12))/简单移动平均(收盘价,12)*100;
Var66:=(收盘价-简单移动平均(收盘价,24))/简单移动平均(收盘价,24)*100;
Var67:=向前引用(收盘价,1);
Var68:=移动平均(最大值(收盘价-Var67,0),5,1)/移动平均(绝对值(收盘价-Var67),5,1)*100;
Var69:=(最高价+最低价+收盘价)/3;
Var6A:=(Var69-简单移动平均(Var69,14))/(0.015*平均绝对偏差(Var69,14));
Var6B:=(Var64>=-15.8 AND Var64<=-12.2 AND Var65<=-20.8 AND Var66<=-27.5 AND Var68<=11.7 AND Var6A<=-145)*100;
Var6C:=Var48=0;
Var6D:=Var48=100;
Var6E:=最低值(最高价,240);
Var6F:=100*(收盘价-Var6E)/Var6E;
Var70:=(收盘价-最低值(最低价,528))/(最高值(最高价,528)-最低值(最低价,528))*100;
Var71:=(收盘价-最低值(收盘价,530))/(最高值(收盘价,530)-最低值(收盘价,530))*100;
Var72:=0;
Var73:=移动平均(最大值(收盘价-向前引用(收盘价,1),0),34,1)/移动平均(绝对值(收盘价-向前引用(收盘价,1)),7,1)*100;
Var74:=移动平均(最大值(收盘价-向前引用(收盘价,1),0),13,1)/移动平均(绝对值(收盘价-向前引用(收盘价,1)),13,1)*100;
Var75:=有效值周期数(收盘价);
Var76:=Var73<20 AND Var74<23 AND Var75>35;
Var77:=Var76 AND 统计总数(Var76,1)=1;
Var78:=指数平滑移动平均(收盘价,21)-指数平滑移动平均(收盘价,8);
Var79:=指数平滑移动平均(Var78,5);
Var7A:=前M个波谷位置(3,6,1)<4 AND 交叉函数(Var78,Var79);
Var7B:=条件函数(前M个波谷位置(3,16,1)=0 AND 最高价>最低价+0.04,4,0);
Var7C:=条件函数(指数平滑移动平均(收盘价,5)/指数平滑移动平均(指数平滑移动平均(收盘价,9),16)<=0.85 AND 收盘价/向前引用(收盘价,1)>0.905 AND 收盘价/向前引用(收盘价,1)<1.05 AND 成交量/流通盘大小*100<5,50,0);
Var7D:=(-100)*(最高值(最高价,34)-收盘价)/(最高值(最高价,34)-最低值(最低价,34))+100;
Var7E:=(-100)*(最高值(最高价,50)-收盘价)/(最高值(最高价,50)-最低值(最低价,50))+100;
Var7F:=(-100)*(最高值(最高价,70)-收盘价)/(最高值(最高价,70)-最低值(最低价,70))+100;
Var80:=((收盘价-简单移动平均(收盘价,34))/简单移动平均(收盘价,34)*100+10)*5;
Var81:=((收盘价-简单移动平均(收盘价,50))/简单移动平均(收盘价,50)*100+10)*5;
Var82:=((收盘价-简单移动平均(收盘价,70))/简单移动平均(收盘价,70)*100+10)*5;
Var83:=(Var7D+Var7E+Var7F+Var80+Var81+Var82)/6;
Var84:=指数平滑移动平均(Var83,3);
Var85:=绝对值(Var80-Var82);
Var86:=(Var83+Var85)/2;
Var87:=(-1)*(指数平滑移动平均(100*(1-获利盘比例(收盘价)),1)-50)+50;
Var88:=Var87+Var86;
Var89:=条件函数(Var7C>0 AND Var88<0,200,0);
Var8A:=条件函数(Var86<0 AND 收盘价=最低值(收盘价,5) AND 收盘价/向前引用(收盘价,1)>0.905 AND 收盘价/向前引用(收盘价,1)<1.05 AND 成交量/流通盘大小*100<5,-50,0);
Var8B:=条件函数(Var88<0 AND Var8A=-50,100,0);
Var8C:=简单移动平均(收盘价,3);
Var8D:=向前引用(收盘价,2)*0.865;
Var8E:=向前引用(收盘价,13)*0.772;
Var8F:=最小值(Var8D,Var8E);
Var90:=100*成交量/流通盘大小;
Var91:=简单移动平均(收盘价,13);
Var92:=条件函数((收盘价-Var8F)/收盘价<0.03 AND 求和(Var90,5)/5<1.8,1,0);
Var93:=条件函数(Var92>0 AND (Var8A<0 OR Var7C>0),100,0);
Var94:=Var93;
Var95:=IF(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0) AND Var93<10,50,0);
Var96:=(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0);
Var97:=Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
Var98:=Var96 OR Var97;
Var99:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
Var9A:=HIGH-REF(HIGH,1);
Var9B:=REF(LOW,1)-LOW;
Var9C:=SMA(IF(Var9A>0 AND Var9A>Var9B,Var9A,0),12,1);
Var9D:=SMA(IF(Var9B>0 AND Var9B>Var9A,Var9B,0),12,1);
Var9E:=Var9C*100/Var99;
Var9F:=Var9D*100/Var99;
VarA0:=SMA(ABS(Var9F-Var9E)/(Var9F+Var9E)*100,12,1);
VarA1:=(VarA0+REF(VarA0,5))/2;
VarA2:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VarA3:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VarA4:=AMOUNT/VOL/100;
VarA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarA6:=SUM(AMOUNT,5)/VarA4/100;
VarA7:=SUM(AMOUNT,13)/VarA4/100;
VarA8:=SUM(AMOUNT,34)/VarA4/100;
VarA9:=SUM(AMOUNT,209)/VarA4/100;
VarAA:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
VarAB:=VarAA/CAPITAL;
VarAC:=VOL/CAPITAL*VarA5+VarAB*REF(VarA4,1);
VarAD:=DMA(VarA5,VOL/VarA6);
VarAE:=DMA(VarA5,VOL/VarA7);
VarAF:=DMA(VarA5,VOL/VarA8);
VarB0:=DMA(VarA5,VOL/CAPITAL);
VarB1:=MA(HHV(HIGH,488),18);
VarB2:=MA(HHV(HIGH,220),18);
VarB3:=MA(HHV(HIGH,98),18);
VarB4:=MA(LLV(LOW,488),18);
VarB5:=MA(LLV(LOW,220),18);
VarB6:=MA(LLV(LOW,98),18);
VarB7:=MA((VarB4*0.96+VarB5*0.96+VarB6*0.96+VarB1*0.558+VarB2*0.558+VarB3*0.558)/6,18);
VarB8:=MA((VarB4*1.25+VarB5*1.23+VarB6*1.2+VarB1*0.55+VarB2*0.55+VarB3*0.65)/6,18);
VarB9:=MA((VarB4*1.3+VarB5*1.3+VarB6*1.3+VarB1*0.68+VarB2*0.68+VarB3*0.68)/6,18);
VarBA:=MA((VarB7*3+VarB8*2+VarB9)/6*1.738,18);
VarBB:=IF(DATE<=1021231,VarBA,VarBA*DAY);
VarBC:=LOW;
VarBD:=REF(LOW,1);
VarBE:=SMA(ABS(VarBC-VarBD),3,1)/SMA(MAX(VarBC-VarBD,0),3,1)*100;
VarBF:=MA(IF(CLOSE*1.35<=VarBB,VarBE*10,VarBE/10),3);
VarC0:=LLV(LOW,30);
VarC1:=HHV(VarBF,30);
VarC2:=IF(LOW<=VarC0,(VarBF+VarC1*2)/2,0);
WXBM:(MA(VarC2 AND CLOSE<COST(1),3) AND (CLOSE-VarAE)/VarAE*100<-11)*118,colorred,linethick2;
{IF(Var7B>0,STICKLINE(Var7B>0,0,130,4,0),IF(Var60>0,STICKLINE(Var60>0,0,100,8,0),0)),colorred , linethick3;}
大黑马:{IF(Var61,DRAWTEXT(Var61 OR Var98,70,'★大黑马'),coloryellow;
黑马:IF(Var60>0,DRAWTEXT(Var60>0,40,'★黑马'),IF(Var7B>0,DRAWTEXT(Var7B>0,120,'★探底'),IF(WXBM,DRAWTEXT(WXBM,120,''),10))))*Var5,colorred ,linethick2;}
{IF(Var61,STICKLINE(Var61,0,120,8,0),IF(Var98,STICKLINE(Var98,0,60,8,0),0))*Var5,coloryellow ,linethick3 ;}
STICKLINE(Var7B>0,0,120,2,0),colorwhite;
STICKLINE(Var60>0,0,80,8,0),colorred;
DRAWTEXT(Var61 OR Var98,70,'★大黑马'),coloryellow;
DRAWTEXT(Var60>0,40,'★黑马'),coloryellow;
DRAWTEXT(Var7B>0,60,'★探底'),colorwhite;
DRAWTEXT(WXBM,100,'BM'),colorred , ;
STICKLINE(Var61,0,120,8,0),colorwhite;
STICKLINE(Var98,0,90,8,0),coloryellow , ;
x:=c-ref(ma(c,20),11);
lgl:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 and c/ref(c,1)>0.905 and c/ref(c,1)<1.05 and VOL/CAPITAL*100<5,50,0);
wr1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*x;
wr2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
wr3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*x;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
s1:=(wr1+wr2+wr3+bias1+bias2+bias3)/6*x;
s2:=ema(s1,3);
s3:=abs(bias1-bias3);
sx:=(s1+s3)/2;
xc1:=(-1)*(ema(100*(1-WINNER(CLOSE)),1)-50)+50;
ccc:=xc1+sx;
zjz:=IF( lgl>0 and ccc<0,200,0)*x;
lxl:=if(sx<0 and c=llV(c,5) and c/ref(c,1)>0.905 and c/ref(c,1)<1.05 and VOL/CAPITAL*100<5,-50,0);
jbj:=if(ccc<0 and lxl=-50,100,0)*x;
ma3:= ma(c,3);
c0:=ref(c,2)*0.865;
c1:=ref(c,13)*0.772;
bot:=MIN(c0,c1);
hsl:=100*vol/capital*x;
ma13:=ma(c,13)*x;
cxc:=if((c-bot)/c<3/100 and sum(hsl,5)/5<1.8,1,0);
vmc:=if(cxc>0 and (lxl<0 or lgl>0),10,0);
满仓:if((vmc>0),120,0),COLORred,linethick3;
DRAWTEXT(满仓>0 AND REF(满仓,1)=0,100,'满仓'),COLORred;
半仓:if(((zjz>0 and jbj>0 and SUM(VOL/CAPITAL*100,5)/5<1) or (cxc>0 and ref(c,1)/ref(c,2)>0.902)) or (((zjz>0 and jbj>0 and SUM(VOL/CAPITAL*100,5)/5<1) or cxc>0) and (lxl<0 or lgl>0)) and vmc<10 ,100,0),COLORmagenta,linethick2;
v93:=(((zjz>0 and jbj>0 and SUM(VOL/CAPITAL*100,5)/5<1) or cxc>0) and (lxl<0 or lgl>0)) ;
v90:=((zjz>0 and jbj>0 and SUM(VOL/CAPITAL*100,5)/5<1) or (cxc>0 and ref(c,1)/ref(c,2)>0.902));
买11:if((v93 or v90),80,0),COLORyellow,linethick2;
Var2q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-Var2q)/Var2q,2);
买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 and ((c-ref(c,2))/c)>0.06,100,0),colormagenta,linethick2;
yy:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
yt:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
st:=if(cross(yt,yy),30,0);
Var5pt:=(HIGH+LOW+CLOSE)/3;
Var6pt:=(Var5pt-MA(Var5pt,14))/(0.015*AVEDEV(Var5pt,14));
Var7pt:=(Var5pt-MA(Var5pt,85))/(0.015*AVEDEV(Var5pt,85));
sa:=IF(Var7pt>=200 AND Var6pt>=150,10,0);
Var3qq:=REF(CLOSE,1);
Var4qq:=SMA(MAX(CLOSE-Var3qq,0),6,1)/SMA(ABS(CLOSE-Var3qq),6,1)*100;
sm:=if(CROSS(80,Var4qq),100,0);
卖11:if((sm and (sa or st)),120,0),colorCCCC33,linethick2;
DRAWTEXT( 卖11>0,110,'卖'),COLORCCCC33;
Varg3:=LLV(HIGH,240);
Varg4:=100*(CLOSE-Varg3)/Var3;
Varg5:=REF(LLV(CLOSE,480),1);
Varg6:=REF(HHV(CLOSE,480),1);
Varg7:=100*(CLOSE-Varg5)/(Varg6-Varg5);
Varg8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
Varg9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VargA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VargB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VargC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VargD:=IF(DATE<120981231,IF(VarC>23.16,VarC,0),0);
VargE:=VargC<1;
VargF:=VargD;
Varg10:=IF(FILTER(Varg8=0 AND VargA<1 AND Varg4<0,5)=1,1,0);
Varg11:=IF(FILTER(Varg8=100 AND VargA=100,5)=1,1,0);
Varg12:=IF(FILTER(Varg9=0 AND VargB<1 AND Varg7<0,5)=1,1,0);
Varg13:=IF(FILTER(Varg9=100 AND VargB=100,5)=1,1,0);
Varg14:=IF(FILTER(Varg4<1 AND Varg7<1,30)=1,1,0);
Varg15:=Varg10 AND Varg12;
Varg16:=Varg11 AND Varg13;
Varg17:=Varg8=0 AND VargE AND Varg14;
Varg18:=Varg15 AND VargE AND Varg14;
Varg19:=Varg8=100 AND VargF;
Varg1A:=Varg16 AND VargF;
大盘方向:= EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),15), , {00050001};
获利:=Varg4,,{00010001};
操盘手:=(CLOSE-LLV(CLOSE,153))/(HHV(CLOSE,153)-LLV(CLOSE,153))*100, , {00010001};
Varg1B:=EMA(CLOSE,2)-EMA(CLOSE,89);
Varg1C:=EMA(Varg1B,30);
Varg1D:=2*(Varg1B-Varg1C)*10;
Varg1E:=POW(Varg1D,3)*0.1+POW(Varg1D,2);
Varg1F:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Varg20:=EMA(Varg1F*0.97,3);
Varg21:=(HIGH+LOW+CLOSE)/3;
Varg22:=(Varg21-MA(Varg21,14))/(0.015*AVEDEV(Varg21,14));
Varg23:=IF(YEAR<2098 AND Varg1D>0.015,Varg1E,0)/4500;
庄线:=Varg23,,{00010001};
Varg24:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
Varg25:=MA(Varg24,48);
Varg26:=CROSS(Varg24,Varg25);
Varg27:=IF(FILTER(Varg26,126)=1,70,0);
Varg28:=REF(CLOSE,1);
Varg29:=SMA(MAX(CLOSE-Varg28,0),6,1)/SMA(ABS(CLOSE-Varg28),6,1)*100;
Varg2A:=SMA(MAX(CLOSE-Varg28,0),12,1)/SMA(ABS(CLOSE-Varg28),12,1)*100;
Varg2B:=SMA(MAX(CLOSE-Varg28,0),24,1)/SMA(ABS(CLOSE-Varg28),24,1)*100;
Varg2C:=IF(FILTER(CROSS(Varg29,Varg2A) AND CROSS(Varg2A,Varg2B) AND CROSS(Varg29,Varg2B),5)=1,50,0);
Varg2D:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Varg2E:=SMA(Varg2D,3,1);
Varg2F:=SMA(Varg2E,3,1);
Varg30:=3*Varg2E-2*Varg2F;
Varg31:=CROSS(Varg30,Varg2E) AND CROSS(Varg30,Varg2F) AND CROSS(Varg2E,Varg2F);
Varg32:=IF(FILTER(Varg31 AND Varg30<25 AND Varg2F<20,5)=1,80,0);
Varg33:=IF(FILTER(Varg17 OR Varg18,1)=1,100,0);
Varg34:=大盘方向<5 AND 获利<0 AND 操盘手=0;
J买: IF(FILTER(Varg34 OR Varg33,30)=1,120,0),linethick2,COLOR009999,{00010001};
DRAWTEXT(J买,100,'"J买"'),COLOR009999 , {00010001};
DRAWICON(J买,J买,1),COLOR009999;
Varg35:=大盘方向>80 AND 操盘手=100 AND Varg29>80 AND Varg30>100;
Varg36:=IF(FILTER(Varg19 AND Varg16 AND VargF,2)=1,100,0);
J卖: IF(FILTER(Varg36 OR Varg35,9)=1,120,0),linethick2,COLORGREEN,{00010001};
DRAWTEXT(J卖,100,'"J卖"'),COLORGREEN , {00010001};
DRAWICON(J卖,J卖,9),COLORGREEN;
Varg37:=IF(FILTER(Varg2C AND Varg29<60 AND Varg2B<40,15)=1,80,0);
M1: IF(FILTER(大盘方向<5 AND Varg2C AND Varg29<60 AND Varg2B<40,15)=1,100,0),colormagenta , {00010001};
DRAWTEXT(M1,90,'"M1"'),colormagenta,{00010001};
Varg38:=IF(FILTER(Varg37 AND Varg32,5)=1,10,0);
M2: IF(FILTER(大盘方向<5 AND Varg37 AND Varg32,5)=1,100,0),COLORYELLOW , {00010001};
DRAWTEXT(M2,90,'"M2"'),COLORYELLOW,{00010001};
Varg39:=IF(FILTER(Varg37 AND Varg32 AND Varg27,5)=1,80,0);
M3: IF(FILTER(大盘方向<5 AND Varg37 AND Varg32 AND Varg27,5)=1,100,0),colorred,linethick2,{00010001};
DRAWTEXT(M3,90,'"M3买"'),COLORYELLOW,{00010001};
Varr2:=CLOSE-REF(CLOSE,1);
Varr3:=IF(CLOSE-REF(CLOSE,1)>=0,Varr2,0);
Varr4:=REF(CLOSE,1)-CLOSE;
Varr5:=IF(CLOSE-REF(CLOSE,1)<=0,Varr4,0);
Varr6:=SUM(Varr3,16)/SUM(Varr5,16);
Varr7:=100-100/(1+Varr6);
Varr8:=EMA(Varr7,16);
Varr9:=EMA(Varr8,8);
VarrA:=EMA(Varr8,45);
VarrB:=Varr8-VarrA;
ADVC:=amount/vol;
ASR:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5);
DPA:="1a0001$VOL"*"1a0001$CLOSE";
DPMA:=EMA(DPA,5)/EMA("1a0001$VOL",5);
CYS:=("1a0001$CLOSE"-DPMA)/DPMA*100;
A1:=INDEXC;
A2:=MA(A1,5);
A3:=MA(A1,20);
A4:=MA(A1,30);
B1:=A4>A2*1.08 AND A3>A2*1.055;
B2:=A2>A1*1.03 and a3>a1*1.13;
ADVC0:=cys<=-2 and b2;
刀:IF(ASR<6 and cys< -2 and ADVC0,100,0),colorred,linethick2;
DRAWICON( 刀,90, 5),colorred;
龙:IF(ASR<6 ,110,0),COLOR66FFCC,linethick2;
DRAWTEXT(CROSS(龙,2.6) OR CROSS(2.6,龙),90, '龙') ,COLOR66FFCC ;
Varbb4:=MA(CLOSE,5);
Varbb5:=MA(CLOSE,10);
Varbb6:=MA(CLOSE,30);
Varbb7:=MA(CLOSE,60);
Varbb8:=EMA(COST(85),7);
Varbb9:=EMA(COST(15),7);
VarbbA:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VarbbB:=Intpart(VarbbA*100)/100;
VarbbC:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VarbbD:=Intpart(VarbbC*100)/100;
VarbbE:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarbbF:=Intpart(VarbbE*100)/100;
DCS:=(EMA(CLOSE,5)-EMA(CLOSE,10))*100,linethick2;
ZCS:=EMA(DCS,9),linethick2;
Varbb10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Varbb11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Varbb12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Varbb13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Varbb14:=REF(ZCS,1);
Varbb15:=ZCS;
Varbb16:=(Varbb15-Varbb14)/3;
Varbb17:=REF(DCS,1);
Varbb18:=DCS;
Varbb19:=Varbb18-Varbb17;
Varbb1A:=OPEN;
Varbb1B:=CLOSE;
DHM:If(Varbb1A<=Varbb4 AND Varbb1A<=Varbb5 AND Varbb1A<=Varbb6 AND Varbb1B>=Varbb4 AND Varbb1B>=VarbbF AND Varbb16>0 AND Varbb19>0,120,0),colormagenta,linethick2;
DRAWTEXT(DHM,80,'"DHM"'),colormagenta,{00010001};
XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
SQX:=MA((CLOSE-XX2)/XX2,10)*0.01;
买3:IF(CROSS(SQX,0) AND LOW/REF(HIGH,1)<1.012,60,0), STICK,COLORWHITE,LINETHICK2;
稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;
买4: IF(REF(SQX,2)=LLV(SQX,20) AND REF(SQX,2)<0.071 AND REF(SQX,2)<REF(SQX,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),60,0),COLORFF00FF,LINETHICK2;
DRAWTEXT( 买3>0,40 ,' 买3'),COLORWHITE;
DRAWTEXT( 稳赚>0,40 ,'稳赚'),COLOR9999FF;
DRAWTEXT( 买4>0,40 , '买4'),COLORFF00FF;

DRAWTEXTEX(1,1,5,30,'金盾股票园 www.xu5188.com'),ColorC0C0C0;
Varj1:=INDEXC;
Varj2:=MA(Varj1,6);
Varj3:=MA(Varj1,24);
Varj4:=MA(Varj1,32);
Varj5:=MA(Varj1,62);
Varj6:=MA(Varj1,105);
Varj7:=Varj5<REF(Varj5,1) AND Varj6<REF(Varj6,1) AND Varj5<Varj6*0.98;
Varj8:=Varj4>Varj2*1.11 AND Varj3>Varj2*1.095;
Varj9:=Varj2>Varj1*0.95;
BF:=Varj7 AND Varj8 AND Varj9 AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) OR CLOSE>0.1,COLORGREEN;

请点击下图进入下载
赞助商链接
下载说明

☉为了达到最快的下载速度,推荐使用迅雷下载本站软件。

☉使用解压缩软件才能正常解压本站提供的软件!
☉下载本站资源,如果服务器暂不能下载请过一段时间重试!

☉本站统一解压码:www.xu5188.com
☉如果遇到什么问题,请联系我们

 

本网提供的公式文件说明:
☉alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
☉fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
☉exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
☉tnc格式股票公式,可以用通达信股票软件引入使用;
☉tni格式股票公式,仅可以用通达信新版本引入使用例如通达信v6.05以上版本,通达 信老版本不能引入;
☉hxf格式股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

☉关于股票公式源码编辑:本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本网就可以有资 料说明编写过程。

网站地图关于我们免责声明联系站长金盾股票园京ICP备10015640号在线QQ:1078885852